Thursday, March 31, 2016

CCNAv2 Completed Packet Tracer 8.4.1.2

Greetings, and welcome to Seeseenayy.
Packet Tracer 8.4.1.2 is our Skills Integration Challenge for this chapter, OSPF and all. It features a crossing of both IPv6 and IPv4 configuration for OSPF, all passed via one router, as shown below in a diagram. 

If you'd like to skip the tutorial, click below to download the packet tracer.

Alternatively, you may read the tutorial below. I urge you at least give it a glance. 
So, like any packet tracer from this chapter, we're going to have to setup OSPF. Do not let the fact there is both IPv4 and IPv6 configuration for this packet tracer, you've done it before if you've been in CCNA, just not with a routing protocol you've configured. If you're afraid of the merging of these two IP systems, may I redirect you to PT 4.1.3.5? Anyways, lets begin.
First, let me place the addressing table so you can see it.





Copied verbatim from the Packet Tracer PDF, bolded more important things: 
In this Skills Integration Challenge, your focus is OSPFv2 and OSPFv3 configurations. You will configure IP addressing for all devices. Then you will configure OSPFv2 routing for the IPv4 portion of the network and OSPFv3 routing for the IPv6 portion of the network. One router will be configured with both IPv4 and IPv6 configurations. Finally, you will verify your configurations and test connectivity between end devices.

So the packet tracer is asking us to configure a network again, with both OSPF versions and IPv4/IPv6. Easy, I'd believe. So, underneath that previous paragraph is our requirements for this lab.





So we know we're going to be configuring OSPF, so lets go ahead and start on our first in line router to configure. Open RA, configure the addresses for all lines from that router. They're on the addressing table.
RA>en
RA#conf t
RA(config)#router ospf 1
OSPF process 1 cannot start. There must be at least one "up" IP interface
RA(config-router)#router-id 1.1.1.1
RA(config-router)#int g0/0
RA(config-if)#ip add 172.31.0.1 255.255.254.0 
RA(config-if)#no sh

%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

RA(config-if)#int s0/0/0
RA(config-if)#ip add 172.31.4.1 255.255.255.252
RA(config-if)#no sh

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

Please note that I did not configure S0/1/0, it is supposed to be S0/0/0. 
Then, just to wrap it up for now, do:
RA(config-if)#router ospf 1
RA(config-router)#passive-interface g0/0

Lets go open up our next router, RB. Remember, this is the router that we have to configure for both IPv4 and IPv6, so be careful. Not hard, but just be cautious, messing up here will fail your packet tracer.

RB>en
RB#conf t
RB(config)#router ospf 1
OSPF process 1 cannot start. There must be at least one "up" IP interface
RB(config-router)#router-id 2.2.2.2
RB(config-router)#int g0/0
RB(config-if)#ip add 172.31.2.1 255.255.254.0 
RB(config-if)#ipv6 address 2001:DB8:1::1/64
RB(config-if)#no sh

Configure the Serial cables for their respective addresses.
RB(config-if)#int s0/0/0
RB(config-if)#ip add 172.31.4.2 255.255.255.252
RB(config-if)#no sh

RB(config-if)#int s0/0/1
RB(config-if)#ipv6 add 2001:DB8:2::1/64
RB(config-if)#no sh

Now, lets add our network commands for OSPF routing.

RB(config-if)#router ospf 1
RB(config-router)#passive-interface g0/0
RB(config-router)#network 172.31.2.0 255.255.254.0 area 0
RB(config-router)#network 172.31.4.0 255.255.255.252 area 0

So, close RB and go back to RA. While doing that, your link-lights for the entire left side of RB should be green. Go into RA and congfigure your OSPF:

RA(config-if)#router ospf 1
RA(config-router)#passive-interface g0/0
RA(config-router)#network 172.31.0.0 255.255.254.0 area 0
RA(config-router)#network 172.31.4.0 255.255.255.252 area 0

You should get one of these after that:
00:23:22: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0/0 from LOADING to FULL, Loading Done

So, close that and go back to RB, it's time to configure the Serial and other connections with IPv6. 

RB(config-router)#int s0/0/1
RB(config-if)#ipv6 ospf 1 area 0
% IPv6 routing not enabled

Just like last packet tracer, we have to go configure to allow IPv6. Enter the unicast routing command again.
RB(config)#ipv6 unicast-routing 

Resume your connetion to the serial interface...
RB(config)#int s0/0/1
RB(config-if)#ipv6 ospf 1 area 0

Then, configure OSPF to the IPv6 section of the router including the other interfaces to that router.
RB(config-if)#ex
RB(config)#ipv6 router ospf 1
RB(config-rtr)#router-id 2.2.2.2
RB(config-rtr)#int g0/0
RB(config-if)#ipv6 ospf 1 area 0
RB(config-if)#ipv6 address fe80::1 link-local
RB(config)#int s0/0/1
RB(config-if)#no sh

Now, our final router configuration, go to RC and configure like we have done before, though this router is exclusively IPv6.
RC>en
RC#conf t
RC(config)#int g0/0
RC(config-if)#ipv6 address fe80::3 link-local
RC(config-if)#ex

RC(config)#ipv6 unicast-routing
RC(config)#ipv6 router ospf 1
%OSPFv3-4-NORTRID: OSPFv3 process 1 could not pick a router-id,please configure manually
RC(config-rtr)#router-id 3.3.3.3
RC(config-rtr)#int g0/0
RC(config-if)#ipv6 ospf 1 area 0
RC(config-if)#int s0/0/0
RC(config-if)#ipv6 add 2001:DB8:2::2/64
RC(config-if)#ipv6 ospf 1 area 0
RC(config-if)#no sh
RC(config-if)#ipv6 ospf 1 area 0
RC(config-if)#int g0/0
RC(config-if)#ipv6 address 2001:DB8:3::1/64
RC(config-if)#no sh (thank you for the catch! see comments below)
RC(config-if)#ex
RC(config)#ipv6 router ospf 1
RC(config-rtr)#pas

RC(config-rtr)#passive-interface g0/0

So, we've configured our routes fully. You must verify this, perhaps a show command like ospf neighbor. Check your progress, all PC information should not be correct, only everything with the routers.

Finally, we need to do the PCs now. When you check your results, the packet tracer displays the IP address needed for the PCs, the default gateway and other PC information is as follows: 


PC-A Configuration
No IPv6 Configuration Present

IPV4 IP Address: 172.31.1.254
IPV4 Link Local Address: 255.255.254.0
IPV4 Default Gateway: 172.31.0.1

PC-B Configuration
IPV4 IP Address: 172.31.3.254
IPV4 Subnet Mask: 255.255.254.0
IPV4 Default Gateway: 173.31.2.1

IPV6 IP Address: 2001:DB8:1::2/64
IPV6 Link Local Address: FE80::1
IPV6 Default Gateway: FE80::1

**Thank you to "Daniel" in the comments for correcting the PC address issues.

PC-C Configuration
No IPv4 Configuration Present

IPV6 IP Address: 2001:DB8:3::2/64
IPV6 Link Local Address: FE80::1
IPV6 Default Gateway: FE80::3

You are done. Check your progress to verify total 100% points.

CCNAv2 Completed Packet Tracer 8.3.3.5

Greetings, and welcome to Seeseenayy.
Packet Tracer 8.3.3.5 details configuration of IPv6 for OSPF, which is (of sorts) a mix of regular OSPF with different addresses and some basic IPv6 configuration commands.
Below is a download for the provided Packet Tracer: 

Alternatively, you may read the tutorial containing the commands to complete this PT.

First, open R1. We're going to first do a command that should be repeated no matter what lab or activity you are working on. Enter your basic commands: 
R1>en
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv6 router ospf 10

This command, the last one shown above, should return with:
% IPv6 routing not enabled

Meaning we must enable unicast routing, or IPv6 Routing:
R1(config)#ipv6 unicast-routing

Then, according to the PDF, we must configure our Process ID, Router ID, and enable OSPFv3 for each interface. So lets first enable OSPF for IPv6 with the following command:

R1(config)#ipv6 router ospf 10

But wait, there's a problem! The output after this command isn't good! 

%OSPFv3-4-NORTRID: OSPFv3 process 10 could not pick a router-id,please configure manually

Okay, so we're going to have to configure the OSPF by ourselves. No big deal. Just give our router the appropriate information according to the PDF (Route, ID, Etc). Note that you shouldn't of exited the interface you get put into when entering the last command. Enter as follows: 

R1's Configuration
R1(config-rtr)#router-id 1.1.1.1   <-- Routing ID
R1(config-rtr)#int g0/0            <-- Manual Interface Conf
R1(config-if)#ipv6 ospf 10 area 0
R1(config-if)#int s0/0/0
R1(config-if)#ipv6 ospf 10 area 0
R1(config-if)#int s0/0/1
R1(config-if)#ipv6 ospf 10 area 0

So, we just repeat this process for each router device. If you need the code for the other two routers, here they are, but the process is very straight-forward.

R2's Configuration, related to R1.

R2>en
R2#conf t
R2(config)#ipv6 unicast-routing
R2(config)#ipv6 router ospf 10
%OSPFv3-4-NORTRID: OSPFv3 process 10 could not pick a router-id,please configure manually
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#int g0/0
R2(config-if)#ipv6 ospf 10 area 0
R2(config-if)#int s0/0/0
R2(config-if)#ipv6 ospf 10 area 0
R2(config-if)#int s0/0/1
R2(config-if)#ipv6 ospf 10 area 0

You should get something like this after configuring R2.
00:02:21: %OSPFv3-5-ADJCHG: Process 10, Nbr 1.1.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done


Now, to configure R3's end...
R3>en
R3#conf t
R3(config)#ipv6 unicast-routing
R3(config)#ipv6 router ospf 10
%OSPFv3-4-NORTRID: OSPFv3 process 10 could not pick a router-id,please configure manually
R3(config-rtr)#router-id 3.3.3.3
R3(config-rtr)#int g0/0
R3(config-if)#ipv6 ospf 10 area 0
R3(config-if)#int s0/0/0
R3(config-if)#ipv6 ospf 10 area 0
R3(config-if)#int s0/0/1
R3(config-if)#ipv6 ospf 10 area 0


You should get both of these if you configured it correctly.
00:04:12: %OSPFv3-5-ADJCHG: Process 10, Nbr 2.2.2.2 on Serial0/0/1 from LOADING to FULL, Loading Done

00:04:14: %OSPFv3-5-ADJCHG: Process 10, Nbr 1.1.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done

And from any router, enter the show protocols command to verify your configuration functionality:

For instance, R3:
R3#show ip protocols

IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 10"
  Interfaces (Area 0)
    GigabitEthernet0/0
    Serial0/0/0
    Serial0/0/1
  Redistribution:
    None

Note "IPv6 Routing Protocol is "ospf 10"". 
That is it. Great success, eh? 


Wednesday, March 30, 2016

CCNAv2 Completed Packet Tracer - H8.2.2.5 (Custom)

Greetings, and welcome to Seeseenayy.
Today I have a custom packet tracer that is good practice for basic OSPF configuration, the first download is the blank version of the packet tracer, and the second is the completed version.
For both versions you will need the PDF!




If you are stuck on something, look at the post before this one-- about the previous lab, it shows exactly what is needed for this lab, as well as other OSPF features.

Alternatively, if you do not wish to download this packet tracer, you may use the command configuration below.

So, we're going to start with the first configuration of our routers. 
First, Open Router 1 (R1), and enter as follows:

Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#int g0/0
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no sh

R1(config-if)#int s0/0/0
R1(config-if)#ip add 192.168.12.1 255.255.255.252
R1(config-if)#no sh

R1(config-if)#int s0/0/1
R1(config-if)#ip add 192.168.13.1 255.255.255.252

R1(config-if)#no sh

Now, Open Router 2 (R2), and enter as follows:
Router>en
Router#conf t
Router(config)#hostname R2

R2(config)#int g0/0
R2(config-if)#ip add 192.168.2.1 255.255.255.0
R2(config-if)#no sh

R2(config-if)#int g0/1
R2(config-if)#ip add 100.100.100.10 255.255.255.0
R2(config-if)#no sh

R2(config-if)#int s0/0/0
R2(config-if)#ip add 192.168.12.2 255.255.255.252
R2(config-if)#no sh

R2(config-if)#int s0/0/1
R2(config-if)#ip add 192.168.23.2 255.255.255.252

R2(config-if)#no sh

Then, Open Router 3 (R3), and enter as follows:
Router>en
Router#conf t
Router(config)#hostname R3

R3(config)#int g0/0
R3(config-if)#ip add 192.168.3.1 255.255.255.0
R3(config-if)#no sh

R3(config-if)#int g0/1
R3(config-if)#ip add 200.200.200.20 255.255.255.0
R3(config-if)#no sh

R3(config-if)#int s0/0/0
R3(config-if)#ip add 192.168.13.2 255.255.255.252
R3(config-if)#no sh

R3(config-if)#int s0/0/1
R3(config-if)#ip add 192.168.23.2 255.255.255.252

R3(config-if)#no sh

After configuring all three routers and PCs with correct addresses, (according to the routing table) we are able to ping our own network. For instance, PC-C on R3 is able to ping 192.168.13.2 (Our Serial Side from R1), 192.168.23.2 (Our Serial Side from R2), and even the Web Server, however, it is not able to reach anything beyond that network. So, we need to configure OSPF. 

Once our IP-Addressing is complete, we must move on to configuring OSPF. 
Close all tabs and open R1 (Router 1)'s configuration and enter as follows:
R1(config)#router ospf 10
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 192.168.13.0 0.0.0.3 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.3 area 0

R1(config-router)#passive-interface g0/0

Close all tabs and open R2 (Router 2)'s configuration and enter as follows:
R2(config)#router ospf 10
R2(config-router)#network 192.168.23.0 0.0.0.3 area 0
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0 
R2(config-router)#network 100.100.100.0 0.0.0.255 area 0
R2(config-router)#network 192.168.12.0 0.0.0.3 area 0
R2(config-router)#passive-interface g0/1

R2(config-router)#passive-interface g0/0

Close all tabs and open R3 (Router 3)'s configuration and enter as follows:
R3(config)#router ospf 10
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#network 200.200.200.0 0.0.0.255 area 0
R3(config-router)#network 192.168.23.0 0.0.0.3 area 0
R3(config-router)#network 192.168.13.0 0.0.0.3 area 0
R3(config-router)#passive-interface g0/1
R3(config-router)#passive-interface g0/0

Finally, verify that your PCs are able to ping each other. (R1 to R3, etc). Alternatively (and reccomended), use the router command to display neighbors from OSPF, your table should look like this:

R2#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:00:33    192.168.12.1    Serial0/0/0
3.3.3.3           0   FULL/  -        00:00:38    192.168.23.2    Serial0/0/1

R3#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:00:36    192.168.13.1    Serial0/0/0
192.168.23.2      0   FULL/  -        00:00:37    192.168.23.2    Serial0/0/1

--------
R1#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.23.2      0   FULL/  -        00:00:33    192.168.12.2    Serial0/0/0

3.3.3.3           0   FULL/  -        00:00:33    192.168.13.2    Serial0/0/1

Tuesday, March 29, 2016

CCNAv2 Completed Packet Tracer 8.2.4.5 w/ Tutorial

Greetings, and welcome to CCNA.
In this packet tracer, we must configure out own network. This activity comes with no PKT file, which implies we have to build our own Packet Tracer Network!
So, according to the diagram, we have three routers and three PCs. Our first step will be placing these on the Packet Tracer Activity...

Here is a download to the completed lab packet tracer, it only is configured with OSPF and is fully functional. 

PT Download

Initial Configuration
Cisco's Required Devices for Topology:
      • 3 Routers (Cisco 1941)
      • 3 PCs
      • Console cables to configure the Cisco IOS devices via the console ports
      • Ethernet and serial cables as shown in the topology

Steps for this process:
1) Place three 1941 Routers in a triangular pattern.
2) Place three PCs, one for each router.
Then, since these routers do not meet our required ports...
1) Go into one of the routers, turn it off, and add the "HWIC-2T" module.
Repeat this step for all routers.
2) Connect the routers to each other via the correct port.
3) Connect the PCs to their respective router via the correct port.
4) Rename each device with it's appropriate name. (R1, R2, R3.. PC-A, PC-B, PC-C)
Verify that your topology matches either as shown below or on the PDF file.

This is how your layout should look right now.


Now, scroll down in the PDF to the Addressing Table.
We're going to configure some things, but first, we must keep in mind of Cisco's rules, as follows.

Cisco's Lab Requirements:
a. Disable DNS lookup.
b. Configure device name as shown in the topology.
c. DO NOT Assign class as the privileged EXEC password.
d. DO NOT Assign cisco as the console and vty passwords.
e. Configure a message of the day (MOTD) banner to warn users that unauthorized access is prohibited.
f. Configure logging synchronous for the console line.
g. Configure the IP address listed in the Addressing Table for all interfaces.
h. Set the clock rate for all DCE serial interfaces at 128000.
i. Copy the running configuration to the startup configuration.

Our first step of actual configuring is to configure R1 with the appropriate addressing, again, as per the address table.
So, we need to configure our defaults such as hostname. Then, our G0/0 interface to our PC, with additional configuration for our Serial connections, which again must be configured with clock rate and so forth:

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int g0/0
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no sh

R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

Configure S0/0/0 with an address and clock-rate...
R1(config-if)#ex
R1(config)#int s0/0/0
R1(config-if)#ip add 192.168.12.1 255.255.255.252
R1(config-if)#clock rate 128000

So, go to our next interface from the same router...
R1(config-if)#int s0/0/1
R1(config-if)#ip add 192.168.13.1 255.255.255.252
R1(config-if)#no sh

Go back to s0/0/0 and "no sh" the interface.
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
R1(config-if)#int s0/0/0
R1(config-if)#no sh

Now, we're going to go back to our topology. Notice how the PCs are connected via Copper Straight-through, yet still appear to be down, even with an assigned address and "no sh"? Right, that means something went wrong, so what we're going to do is change Straight-through to Crossover, which should then change the "LED Status" from the PC to the Router to GREEN/UP.
For some reason, auto-sense is disabled or incorrect between the router and the PC. Make sure when you use crossover you use "no sh" to prevent any issues later on.
Your 

At this point, all lines from the PCs should be down except PC-As, which we will now fix by configuring out next router. I chose Router 2 (R2), but you may pick another if you'd like.
This is how your topology should look like as of now.


Give our router the basic configuration addressing. We will return to configure the other basics, such as banner MOTDs or passwords, but for now we're exclusively making our addressing scheme work:

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int g0/0
R2(config-if)#ip add 192.168.2.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

Now, we must configure our serial connection for R2.

R2(config-if)#ex
R2(config)#int s0/0/0
R2(config-if)#ip add 192.168.12.2 255.255.255.252
R2(config-if)#no sh

And then for our other serial connection, out of S0/0/1. Remeber, this interface is our interface where clock-rate will need to be configured.

R2(config-if)#ex
R2(config)#int s0/0/1
R2(config-if)#ip add 192.168.23.1 255.255.255.252
R2(config-if)#clock rate 128000
R2(config-if)#no sh
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

We are now done with that part for R2, close the configuration window. You should have green lights (LEDs) from R2's S0/0/0 and G0/0 port, as well as green light/LEDs from R1's S0/0/0 and G0/0 ports. If they are not like this, reconfigure and check your steps.

If you are successful in your current progress, resume and go to R3 for configuring.

Router>
Router>en
Router#conf t
Router#hostname R3
R3(config)#int g0/0
R3(config-if)#ip add 192.168.3.1 255.255.255.0
R3(config-if)#no sh
R3(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
ex (<--- this is a command that got cut by the output)

Again, this port is our DCE ClockRate Serial connection, so we must configure it as so, as we have done before:
R3(config)#int s0/0/0
R3(config-if)#ip add 192.168.13.2 255.255.255.252
R3(config-if)#clock rate 128000
R3(config-if)#no sh
R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

As well as our non-clocked connection:
R3(config)#
R3(config)#int s0/0/1
R3(config-if)#ip add 192.168.23.2 255.255.255.252
R3(config-if)#no sh
R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

Okay, so after configuring as above, EVERYTHING should be working properly with good green LED indications for EVERY port on your topology. Nothing should be down, if it is, you incorrectly configured your packet tracer-- please go back and resume when you have fixed it.
Your PT should match this diagram is some way.

Resuming, we have to configure our PCs. Here is each configuration for all PCs.

PC-A's Desktop IP-Config:
IP: 192.168.1.3
SM: 255.255.255.0
DG: 192.168.1.1

PC-B's Desktop IP-Config:
IP: 192.168.2.3
SM: 255.255.255.0
DG: 192.168.2.1

PC-C's Desktop IP-Config:
IP: 192.168.3.3
SM: 255.255.255.0
DG: 192.168.3.1

Now that we've done most of our general configuration, lets start with OSPF! Yay!
So that Packet Tracer's PDF says we need to keep our "area" setting on OSPF to 0.
The PDF provides us with commands, so we end up with this as our configuration on R1:

On our R1, enter as follows to network our addresses:
R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.3 area 0
R1(config-router)#network 192.168.13.0 0.0.0.3 area 0

Apply the same process with R2:
R2(config)#router ospf 1
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#network 192.168.12.0 0.0.0.3 area 0
R2(config-router)#network 192.168.23.0 0.0.0.3 area 0
00:31:33: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.13.1 on Serial0/0/0 from LOADING to FULL, Loading Done

See that last message after the last #network configuration? I think we did something right!
Now, this means we're done configuring R2, so lets move onto R3 for our final configuration of this type:

R3(config)#router ospf 1
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#network 192.168.13.0 0.0.0.3 area 0
R3(config-router)#network 192.168.23.0 0.0.0.3 area 0
Inbetween configuring this I was cut off by the message we want to see (%OSPF-5-ADJCHG: Process 1, Nbr 192.168.13.1 on Serial0/0/0...), indicating our route is up from that line. You should get two of these messages:
00:31:20: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.1 on Serial0/0/0 from LOADING to FULL, Loading Done

00:33:57: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.2 on Serial0/0/1 from LOADING to FULL, Loading Done
^ That's important information for any OSPF activity.

So, we're done with what we need to do with OSPF. Now we need to verify we did everything properly. Unsurprisingly, we need to use a show command, so go into R1 and enter this:

R1#show ip ospf neighbor
This command then yields this output, which should be correct:
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.23.1      0   FULL/  -        00:00:30    192.168.12.2    Serial0/0/0
192.168.23.2      0   FULL/  -        00:00:38    192.168.13.2    Serial0/0/1

A cool little fact here that explains OSPF. See the address "192.168.12.2"? That comes from R2s S0/0/0! This means your neighboring rotue has worked correctly! But we still need to see our routes.
Enter "show ip route" on R1.
R1#show ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.23.1      0   FULL/  -        00:00:30    192.168.12.2    Serial0/0/0
192.168.23.2      0   FULL/  -        00:00:38    192.168.13.2    Serial0/0/1
(Hey, our table is there again! How about it...)

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
L       192.168.1.1/32 is directly connected, GigabitEthernet0/0
O    192.168.2.0/24 [110/65] via 192.168.12.2, 00:09:33, Serial0/0/0
O    192.168.3.0/24 [110/65] via 192.168.13.2, 00:06:56, Serial0/0/1
     192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.12.0/30 is directly connected, Serial0/0/0
L       192.168.12.1/32 is directly connected, Serial0/0/0
     192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.13.0/30 is directly connected, Serial0/0/1
L       192.168.13.1/32 is directly connected, Serial0/0/1
     192.168.23.0/30 is subnetted, 1 subnets
O       192.168.23.0/30 [110/128] via 192.168.13.2, 00:06:46, Serial0/0/1
=======
So this information shows us present routes within our router, and if you cross-check the addressing table with the route this provides, it seems to be correct.
Keep this information in mind! Lets go see what the other routers have to say about neighboring routes.

A question on the PDF file asks, "What command would you use to only see the OSPF routes in the routing table?". We already entered the command to answer this, which is "show ip route ospf", as shown above.

Related, using this command is how you can debug and test if you're configuring OSPF properly. If your router cannot see the neighbors (in this case there should be two), you are incorrectly configuring OSPF.

Adapted from the PDF, verbatim:
The show ip protocols command is a quick way to verify vital OSPF configuration information. This information includes the OSPF process ID, the router ID, networks the router is advertising, the neighbors the router is receiving updates from, and the default administrative distance, which is 110 for OSPF.

Enter "show ip ospf" on R1 to display this information:
R1#show ip ospf
 Routing Process "ospf 1" with ID 192.168.13.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 6 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x0207cc
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

So for the next few steps it's all general checking with "show this show that", I'm sure you can check yourself, so I'll move on to not bore you any further. We must now verify end-to-end connectivity. Go to PC-A and ping 192.168.2.3:

PC>ping 192.168.2.3

Pinging 192.168.2.3 with 32 bytes of data:

Request timed out.
Reply from 192.168.2.3: bytes=32 time=1ms TTL=126
Reply from 192.168.2.3: bytes=32 time=9ms TTL=126
Reply from 192.168.2.3: bytes=32 time=6ms TTL=126

Ping statistics for 192.168.2.3:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 9ms, Average = 5ms

PC>ping 192.168.2.3

Pinging 192.168.2.3 with 32 bytes of data:

Reply from 192.168.2.3: bytes=32 time=1ms TTL=126
Reply from 192.168.2.3: bytes=32 time=17ms TTL=126
Reply from 192.168.2.3: bytes=32 time=10ms TTL=126
Reply from 192.168.2.3: bytes=32 time=1ms TTL=126

Ping statistics for 192.168.2.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 17ms, Average = 7ms

Again, in PC-A's command line, attempt to ping "192.168.3.3", you should get the following.
PC>ping 192.168.3.3

Pinging 192.168.3.3 with 32 bytes of data:

Request timed out.
Reply from 192.168.3.3: bytes=32 time=3ms TTL=126
Reply from 192.168.3.3: bytes=32 time=9ms TTL=126
Reply from 192.168.3.3: bytes=32 time=1ms TTL=126

Ping statistics for 192.168.3.3:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 9ms, Average = 4ms

PC>ping 192.168.3.3

Pinging 192.168.3.3 with 32 bytes of data:

Reply from 192.168.3.3: bytes=32 time=2ms TTL=126
Reply from 192.168.3.3: bytes=32 time=1ms TTL=126
Reply from 192.168.3.3: bytes=32 time=1ms TTL=126
Reply from 192.168.3.3: bytes=32 time=3ms TTL=126

Ping statistics for 192.168.3.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 3ms, Average = 1ms

If you're only looking to do the OSPF Configuration, such as Packet Tracer Turnins for a working OSPF system, you are done. Verify  your network prior to submitting.

Okay, great, we've gotten our network to work, now what? We're nowhere near done! Now, we must configure OSPF to include "Router ID", which is used to uniquely identify the router in the OSPF routing domain, which is possible in one of three ways following precedence (in important order):

1) IP address configured with the router-id command, if present.
2) Highest IP address of any of the router's loopback addresses, if present.
3) Highest active IP address on any of the router's physical interfaces.

Because no Router IDs or loop-back interfaces have been configured on the three routers, the router-id is determined, by default, by the highest IP address of any active interface. Now, what we're going to have to do is drawn out into three parts, which means we will be doing all three of the options above.

As per instructions, we must assign an interface loopback address of 0 to R1. So, Assign an IP address to loopback 0 on R1:
R1(config)# interface lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#no sh
R1(config-if)#end

Then, Assign IP addresses to Loopback 0 on R2 and R3. Use IP address 2.2.2.2/32 for R2 and 3.3.3.3/32 for R3.
R2 Loopback Configuration
R2(config)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255

R2(config-if)#end

R3 Loopback Configuration
R3(config)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.255

R3(config-if)#end

Save all configs on your routers by entering "wr" or the full-length command ("copy run start") to save progress. Save your packet tracer file now.


Save your packet tracer file prior to entering the reboot or even wr/copy run start cmd
IF YOU DO NOT SAVE YOUR WORK YOU WILL LOSE 
ALL PROGRESS MADE TO THE ROUTER YOU REBOOTED.

Now, from the PDF Instructions directly:
You must reload the routers in order to reset the router ID to the loopback address. Issue the reload command on all three routers. Press Enter to confirm the reload

Go to your router and enter this command:
R1#reload
Proceed with reload? [confirm] 
...

R2#reload
Proceed with reload? [confirm]
...

R3#reload
Proceed with reload? [confirm]
...

Notice how your the routes/connections from each router you enter the reboot command go down from a previously green and solid up?


Finally, save the running configuration to the startup configuration on all three routers.
For the sake of time and length, I'm going to skip the show commands once again, the PDF does a wonderful job at explaining it. 

Assigning Router-IDs and Clearing R1's IP Process. 
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#router-id 11.11.11.11

R1#clear ip ospf process
Reset ALL OSPF processes? [no]: yes (you have to type this)

R1#
00:05:50: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.1 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:05:50: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.1 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached

00:05:50: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

00:05:50: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached


Now we would repeat this step for R2. 
R2>en
R2#conf t
R2(config)#router ospf 1
R2(config-router)#router-id 22.22.22.22
R2(config-router)#Reload or use "clear ip ospf process" command, for this to take effect

And so forth.
This is not the entire packet tracer, I know, but this is as far as you need for BASIC OSPF configuring. I will post the later and uncovered information when I get to it.