Friday, April 15, 2016

CCNAv2 Completed Packet Tracer 10.1.2.4

Greetings, and welcome to Seeseenayy.

Packet Tracer Details: This packet tracer asks us to configure basic DHCP on a router, giving us the option to configure DHCP from the routers, as well as relays and other.

Below you will find a download of the completed packet tracer file. It is recommended that you read the tutorial or so.


Download(s)
### PDF answers are in the tutorial ###

Alternatively, you may use the commands from the tutorial.

Tutorial / Walk-through 
First, we need to configure our basic addressing. Start with R1, and configure those with the appropriate addresses.

R1 Configuration (Basic)
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#int g0/0
R1(config-if)#ip add 192.168.0.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int g0/1
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int s0/0/0
R1(config-if)#clock rate 128000
R1(config-if)#ip add 192.168.2.253 255.255.255.252
R1(config-if)#no sh

R2 Configuration (Basic)
Router>en
Router#conf t
Router(config)#hostname R2
R2(config)#int s0/0/0
R2(config-if)#ip add 192.168.2.254 255.255.255.252
R2(config-if)#no sh
R2(config-if)#int s0/0/1
R2(config-if)#clock rate 128000
R2(config-if)#ip add 209.165.200.226 255.255.255.224
R2(config-if)#no sh

ISP Configuration (Basic)
Router>en
Router#conf t
Router(config)#hostname ISP
ISP(config)#int s0/0/1
ISP(config-if)#ip add 209.165.200.225 255.255.255.224
ISP(config-if)#no sh

Then, we must configure those OSPF and IPv4 Routes for the same routers.

R1 Configuration (OSPF/ROUTE)
R1(config-if)#ex
R1(config)#router ospf 1
R1(config-router)#network 192.168.0.0 0.0.0.255 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.2.252 0.0.0.3 area 0

R2 Configuration (OSPF/ROUTE)
R2(config-if)#ex
R2(config)#router ospf 1
R2(config-router)#network 192.168.2.252 0.0.0.3 area 0
R2(config-router)#network 192.168. 0.0.0.3 area 0
R2(config-router)#default-information originate
R2(config-router)#ex
R2(config)#ip route 0.0.0.0 0.0.0.0 209.165.200.225

ISP Configuration (OSPF/ROUTE)
ISP(config)#ip route 192.168.0.0 255.255.252.0 209.165.200.226

Then we need to configure our DHCP for the routers, both to allow it and relay.

R2 Configuration (DHCP)
R2(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.9
R2(config)#ip dhcp pool R1G0
R2(dhcp-config)#network 192.168.0.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.0.1
R2(dhcp-config)#dns-server 209.165.200.225
R2(dhcp-config)#ex
R2(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.9
R2(config)#ip dhcp pool R1G1
R2(dhcp-config)#network 192.168.1.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.1.1
R2(dhcp-config)#dns-server 209.165.200.225

R2 should be set up. Try using DHCP from PC-A and PC-B to get IP addresses.

On PC-A or PC-B, open a command prompt and enter the ipconfig /all command. Did either PC receive an P address from the DHCP server? Why?
- The host computers did not receive an IP address from the DHCP server at R2 until R1 is configured a relay agent for DHCP.

Since R1 is not configured as a relay agent, we must configure R1 to be an agent to get DHCP (if configured this way in a non-hypothetical situation).
R1>en
R1#conf t
R1(config)#int g0/0
R1(config-if)#ip helper-address 192.168.2.254
R1(config-if)#exit
R1(config)#int g0/1
R1(config-if)#ip helper-address 192.168.2.254
R1(config-if)#exit
R1(config)#

Based on the DHCP pool that was configured on R2, what are the first available IP addresses that PC-A and PC-B can lease?
- PC-B: 192.168.0.10
- PC-A: 192.168.1.10

We then must verify the DHCP services and leases.
Your output should be the same as this below.

R2#show ip dhcp binding
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
192.168.0.10     000A.413A.2D01           --                     Automatic
192.168.1.10     00D0.BA11.6D66           --                     Automatic


Along with the IP addresses that were leased, what other piece of useful client identification information is in the output?
- The client hardware addresses identify the specific computers that have joined the network.


On R2, enter the show ip dhcp server statistics command to view the DHCP pool statistics and message activity. How many types of DHCP messages are listed in the output?
- Ten types.


On R2, enter the 'show ip dhcp pool' command to view the DHCP pool settings? In the output of the show ip dhcl pool command, what does the current index refer to?
- The next available address for leashing.

You can check what you've applied in DHCP on that router using the show run command in place of the method referred to in the PDF.
R2#show run
ip dhcp excluded-address 192.168.0.1 192.168.0.9
ip dhcp excluded-address 192.168.1.1 192.168.1.9

ip dhcp pool R1G0
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 209.165.200.225
ip dhcp pool R1G1
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 209.165.200.225
 
 
 Likewise, on R1, you can verify DHCP relay is enabled for those ports.
 See below, the bolded/colored text is the relay command to prove we configured it.
 
 interface GigabitEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 ip helper-address 192.168.2.254
 duplex auto
 speed auto

interface GigabitEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip helper-address 192.168.2.254
 duplex auto
 speed auto

Your configuration should be done then.

What do you think is the benefit of using DHCP relay agents instead of multiple routers acting as DHCP servers?
Having a seperate router DHCP server for each subnet would add more complexity, decrease centralized management for the network, as well as requiring each router to work harder by managing it's own DHCP while already routing traffic. One DHCP Server (RT/PC) that is dedicated is easier to manage and is more centralized.


No comments:

Post a Comment

Feel free to comment if you have a question, commendation, or concern. We love to hear your feedback!

Please do not share links to external websites if it not relevant to discussion. We reserve our right to remove any content we deem advertising.