Friday, March 18, 2016

CCNAv2 Completed Custom PT - RIPv2

Greetings, and welcome to Seeseenayy.
Today we were given a custom packet tracer about RIP, which is VERY Easy.
RIP is extremely easy and the future protocols only go down-hill from here.


Here is the completed version.

PKT Completed - RIPv2

I strongly urge you to read the tutorial. 
Alternatively, if you don't want to download the file, read the tutorial below.
TUTORIAL

Above is how this packet tracer should look when first opened, note the link-lights on the cables, indicating that most, if not all, links are down for one reason or another.

Our first goal, obviously, is to turn on the link-lights by powering on the devices that may be off:

1. 

Turn on LasVegas by clicking the Power tab in Physical. You can either enable the G0/1 + G0/0 ports through "config" or enable them by entering "no sh" in the CLI. I did the first option.

2. Enable the ports in the routers, such as G0/0 & G0/1 and the proper Serial port, if applicable. Below is the configuration print for a completed Las Vegas router, please continue.

Router - Las Vegas, Configuration
interface GigabitEthernet0/0
ip address 172.36.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 180.51.0.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 221.221.221.1 255.255.255.0
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!

Vegas Router RIP Configuration
router rip
version 2
redistribute static
passive-interface GigabitEthernet0/0
passive-interface GigabitEthernet0/1
network 172.36.0.0
network 180.51.0.0
network 221.221.221.0
default-information originate
no auto-summary


Explained of R1
01 Router(config)#router rip
02 Router(config-router)#version 2
03 Router(config-router)#passive-interface G0/0
04 Router(config-router)#passive-interface G0/1
05 Router(config-router)#network 172.36.0.0
06 Router(config-router)#network 180.51.0.0
07 Router(config-router)#network 221.221.221.0
08 Router(config-router)#default-information originate
09 Router(config-router)#no auto-summary

Explanation 
0. Get into your configuration level, easy.
1. You want to tell the router that it needs to use RIP, so you use the command as shown.
2. To build on step one, you need to specificity which version to use, as the "default" is chosen. We want to use Version 2.

3 & 4. Passive-Interface is a command which is used to disable routing updates from being sent out a specific interface (in this case, it's both interfaces that don't contain routers) while still advertising the connected network to other routers. This command changes a bit with EIGRP but we don't need to worry about it now. In a nutshell, the interface affected by this command will only listen for advertisements, not send them.

5, 6, & 7. The network command actually tells the router which connected network(s) are to be advertised, as well as the router interface(s) that you want to participate in the RIP process. Specifically, for step 7, we use the serial address for the same purpose we use an IP address of the LANs by the router.

8. This command is executed in RIP router configuration mode to configure RIP to advertise a default route throughout the RIP routing domain.

9. By default routing protocol like RIP and EIGRP summarize subnets into major classful network at classful boundary. In other word, these protocols perform an auto-summarization each time they crosses a border between two different major networks. To disable this behavior and advertise subnets, 'no auto-summary' command is used. 

Router - Denver, Configuration
interface GigabitEthernet0/0
ip address 185.11.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 221.221.221.2 255.255.255.0
clock rate 2000000
!
interface Serial0/0/1
ip address 220.220.220.1 255.255.255.0
clock rate 2000000

RIP Configuration on R2 (Denver)
router rip
version 2
passive-interface GigabitEthernet0/0
network 185.11.0.0
network 220.220.220.0
network 221.221.221.0
default-information originate
no auto-summary

Router - Boston, Configuration
interface GigabitEthernet0/0
ip address 190.28.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 147.5.0.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
ip address 220.220.220.2 255.255.255.0
!

Boston RIP Configuration
router rip
version 2
redistribute static
passive-interface GigabitEthernet0/0
passive-interface GigabitEthernet0/1
network 147.5.0.0
network 190.28.0.0
network 220.220.220.0
default-information originate
no auto-summary






No comments:

Post a Comment

Feel free to comment if you have a question, commendation, or concern. We love to hear your feedback!

Please do not share links to external websites if it not relevant to discussion. We reserve our right to remove any content we deem advertising.